foresta profonda

眠くない日はない。

Raspberry PiでRuby

Raspberry Pi上でRubyが使えるようにしてみます。

$ sudo apt-get install ruby1.8-full rubygems

基本的な環境はこれでインストールされる模様。
試しにTwitter投稿できるgemをインストールしてみる。

$ sudo gem install tw system_timer

が、以下のようなエラーが発生。

$ sudo gem install tw system_timer
Building native extensions.  This could take a while...
ERROR:  Error installing tw:
    ERROR: Failed to build gem native extension.

        /usr/bin/ruby1.9.1 extconf.rb
/usr/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in `require': cannot load such file -- mkmf (LoadError)
    from /usr/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in `require'
    from extconf.rb:1:in `<main>'


Gem files will remain installed in /var/lib/gems/1.9.1/gems/http_parser.rb-0.6.0 for inspection.
Results logged to /var/lib/gems/1.9.1/gems/http_parser.rb-0.6.0/ext/ruby_http_parser/gem_make.out
Building native extensions.  This could take a while...
ERROR:  Error installing system_timer:
    ERROR: Failed to build gem native extension.

        /usr/bin/ruby1.9.1 extconf.rb
/usr/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in `require': cannot load such file -- mkmf (LoadError)
    from /usr/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in `require'
    from extconf.rb:2:in `<main>'


Gem files will remain installed in /var/lib/gems/1.9.1/gems/system_timer-1.2.4 for inspection.
Results logged to /var/lib/gems/1.9.1/gems/system_timer-1.2.4/ext/system_timer/gem_make.out

mkmfが無いと怒ってはるので入れてあげる。
apt-getでruby-devをインストールしてあげると良いらしい。

$ sudo apt-get install ruby-dev

この後、再度twをインストールすればちゃんと入ってくれる。

twコマンドを叩くと認証用のURLが表示されるので、
ブラウザでアクセスして、表示された番号で
認証すればtwコマンドが使えるようになる。

【参考】
http://shokai.org/blog/archives/6857

広告を非表示にする